~comcloudway/ccw-aports

8d0b2c3f15bfcccc49a32c8f8bbeaa5d6c450b76 — Jakob Meier 1 year, 11 months ago fbeee3f
testing/libgc: new aport
conflicts with glibc, and thus moved into broken
1 files changed, 38 insertions(+), 0 deletions(-)

A broken/libgc/APKBUILD
A broken/libgc/APKBUILD => broken/libgc/APKBUILD +38 -0
@@ 0,0 1,38 @@
# Contributor: Jakob Meier <comcloudway@ccw.icu>
# Maintainer: Jakob Meier <comcloudway@ccw.icu>
pkgname=libgc
pkgver=8.2.2
pkgrel=0
pkgdesc="The Boehm-Demers-Weiser conservative C/C++ Garbage Collector"
url="https://github.com/ivmai/bdwgc"
arch="all"
license="MIT"
depends=""
makedepends=""
checkdepends=""
subpackages="$pkgname-dev $pkgname-doc"
source="libgc-$pkgver.tar.gz::https://github.com/ivmai/bdwgc/releases/download/v$pkgver/gc-$pkgver.tar.gz"
builddir="$srcdir/gc-$pkgver"

build() {
	./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--sysconfdir=/etc \
		--mandir=/usr/share/man \
		--localstatedir=/var
	make -j
	make check
}

check() {
	make check
}

package() {
	DESTDIR="$pkgdir" make install
}
sha512sums="
4a7b26789ce22ab72bfaadf3029362c5fe26737df1e856e43db7d9b24ee8acf625e35d596bb3f698f91d6a5ddfb6c45a952a1dbd18d47359569696a544c9c248  libgc-8.2.2.tar.gz
"