A testing/libexecinfo/APKBUILD => testing/libexecinfo/APKBUILD +27 -0
@@ 0,0 1,27 @@
+# Contributor: Jakob Meier <comcloudway@ccw.icu>
+# Maintainer: Jakob Meier <comcloudway@ccw.icu>
+pkgname=libexecinfo
+pkgver=1.0
+pkgrel=1
+pkgdesc="BSD licensed clone of backtrace facility found in the GNU libc"
+url="https://github.com/ronchaine/libexecinfo"
+arch="all"
+license="BSD"
+depends=""
+makedepends=""
+checkdepends=""
+subpackages="$pkgname-dev"
+source="exec-info.zip::https://github.com/ronchaine/libexecinfo/archive/refs/heads/master.zip"
+builddir="$srcdir/libexecinfo-master"
+options="!check"
+
+build() {
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir/" make install
+}
+sha512sums="
+76a4dbb52a8b93354474e598d9771bd8805dfbb6fd1caf6274d378e03091dd583a05fbb8a74c40d07671bf41399dc508e1d0d1a5b7fc85c14ffe7f283a349442 exec-info.zip
+"