~comcloudway/ccw-aports

566f38c8e15a116708f0b37664e30f0402006152 — Jakob Meier 1 year, 1 month ago 703b0fd
main/little-town: new aport
2 files changed, 51 insertions(+), 0 deletions(-)

A main/little-town/APKBUILD
A main/little-town/fix-musl.patch
A main/little-town/APKBUILD => main/little-town/APKBUILD +42 -0
@@ 0,0 1,42 @@
# Maintainer: Jakob Meier <comcloudway@ccw.icu>
pkgname=little-town
pkgver=0.2.3-r4
pkgrel=0
pkgdesc="Design your own isometric world"
url="https://codeberg.org/comcloudway/little_town"
arch="all"
license="AGPL-3.0"
makedepends="cargo alsa-lib alsa-lib-dev protoc wget unzip ffmpeg bash"
builddir="$srcdir/little_town"
source="
    little-town-$pkgver.tar.gz::https://codeberg.org/comcloudway/little_town/archive/v$pkgver.tar.gz
	fix-musl.patch
"
options="net"

prepare() {
	default_prepare

    ./fetch-assets.sh

	cargo fetch --target="$CTARGET"
	cargo update -p libc
}

build() {
	cargo build --release
}

check() {
	cargo test --frozen
}

package() {
	cargo install --frozen --offline --path . --root="$pkgdir/usr"
	rm "$pkgdir"/usr/.crates*
}

sha512sums="
aba2d5d73038d75ce28ff90edf329ec5f702172eac50e993e83f8a6e0c4a334feeb8cb3fcf7baeb5f16d0238b2ee9b8c2b9e075096a17fbb00dfbf35f3a9978b  little-town-0.2.3-r4.tar.gz
8eaa642405335205e2758f99a35eaa94ca01ccf6ad4508119fbe14c934b51cd781f57bb39450898f39ca59f04f3e985413914ee21d011ec8ce622d6802eecbe1  fix-musl.patch
"

A main/little-town/fix-musl.patch => main/little-town/fix-musl.patch +9 -0
@@ 0,0 1,9 @@
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,3 +30,6 @@
 quad-rand = { version = "0.2.1", optional = true }
 quad-snd = "0.2.7"
 async-trait = "0.1.73"
+
+[patch.crates-io]
+libc = { git = "https://github.com/rust-lang/libc" }