experimental: forgejo actions demo
1 files changed, 17 insertions(+), 0 deletions(-) A .forgejo/workflows/check-all.yml
A .forgejo/workflows/check-all.yml => .forgejo/workflows/check-all.yml +17 -0
@@ 0,0 1,17 @@ --- on: [push] jobs: demo: runs-on: docker container: image: alpine:edge steps: - name: Install checkout dependencies run: apk add nodejs git - name: Checkout uses: actions/checkout@v2 - name: Install tools run: apk add atools - name: Check all APKBUILDs run: find . -iname 'APKBUILD' | xargs -n 1 apkbuild-lint