~comcloudway/ccw-aports

f88fd384ab4f609d58b45ae4f7d6b54a7b5e5333 — Jakob Meier 1 year, 1 month ago 48f17fc
experimental: forgejo actions demo
1 files changed, 17 insertions(+), 0 deletions(-)

A .forgejo/workflows/check-all.yml
A .forgejo/workflows/check-all.yml => .forgejo/workflows/check-all.yml +17 -0
@@ 0,0 1,17 @@
---
on: [push]
jobs:
  demo:
    runs-on: docker
    container:
      image: alpine:edge

    steps:
      - name: Install checkout dependencies
        run: apk add nodejs git
      - name: Checkout
        uses: actions/checkout@v2
      - name: Install tools
        run: apk add atools
      - name: Check all APKBUILDs
        run: find . -iname 'APKBUILD' | xargs -n 1 apkbuild-lint