~comcloudway/ccw-aports

e2913c44cf0e3b7fd684f47cb72b4420e0436592 — Jakob Meier 6 months ago 0666d60
remove fix-musl patches, as they are no longer needed
8 files changed, 0 insertions(+), 53 deletions(-)

M main/little-town/APKBUILD
D main/little-town/fix-musl.patch
M main/oomph/APKBUILD
D main/oomph/fix-musl.patch
M main/polarplayer-studio/APKBUILD
D main/polarplayer-studio/fix-musl.patch
M testing/suitsquad/APKBUILD
D testing/suitsquad/fix-musl.patch
M main/little-town/APKBUILD => main/little-town/APKBUILD +0 -2
@@ 11,7 11,6 @@ makedepends="cargo alsa-lib alsa-lib-dev protoc wget unzip ffmpeg bash"
builddir="$srcdir/little_town"
source="
	little-town-$_pkgver.tar.gz::https://codeberg.org/comcloudway/little_town/archive/v$_pkgver.tar.gz
	fix-musl.patch
	LittleTown.desktop
"
options="net"


@@ 47,6 46,5 @@ package() {

sha512sums="
aba2d5d73038d75ce28ff90edf329ec5f702172eac50e993e83f8a6e0c4a334feeb8cb3fcf7baeb5f16d0238b2ee9b8c2b9e075096a17fbb00dfbf35f3a9978b  little-town-0.2.3-r4.tar.gz
8eaa642405335205e2758f99a35eaa94ca01ccf6ad4508119fbe14c934b51cd781f57bb39450898f39ca59f04f3e985413914ee21d011ec8ce622d6802eecbe1  fix-musl.patch
1c52648f2287f2b5a715ef90513d576ac75d9db0becc5a936e9e50083c5807b02fc982fa7f1027b7973e9744b605430f2e9baab4da7cad4bf4092799a29c8894  LittleTown.desktop
"

D main/little-town/fix-musl.patch => main/little-town/fix-musl.patch +0 -9
@@ 1,9 0,0 @@
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,3 +30,6 @@
 quad-rand = { version = "0.2.1", optional = true }
 quad-snd = "0.2.7"
 async-trait = "0.1.73"
+
+[patch.crates-io]
+libc = { git = "https://github.com/rust-lang/libc" }

M main/oomph/APKBUILD => main/oomph/APKBUILD +0 -2
@@ 10,7 10,6 @@ license="AGPL-3.0-or-later"
makedepends="cargo"
source="
oomph-v$pkgver.tar.gz::https://codeberg.org/comcloudway/oomph/archive/v$pkgver.tar.gz
fix-musl.patch
"
builddir="$srcdir/oomph"
options="net"


@@ 35,5 34,4 @@ package() {
}
sha512sums="
76bdec15353effdcbbf121d9a88534adf1f39b27136aa7500221a26b975dc5c7ad6f838abfee5372411da7cfb0eb237c2819a6657df9d172913e1f2c0f48e624  oomph-v0.3.0.tar.gz
bd76265e90d46c7d6b9075b16ea19b5b1f5e98a4e7d8afd096afdeea62b97cece486030053b6a75a152ada4260f227064d6695ccd5166f65e1ce775a452956f2  fix-musl.patch
"

D main/oomph/fix-musl.patch => main/oomph/fix-musl.patch +0 -12
@@ 1,12 0,0 @@
diff --git a/Cargo.toml b/Cargo.toml
index 6af468b..e265dff 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,3 +17,7 @@ serde_json = "1.0"
 clap = { version = "4.1.8", features = [ "derive" ] }
 
 chrono = "0.4.23"
+
+[patch.crates-io]
+getrandom = { git = "https://github.com/comcloudway/getrandom" }
+libc = { git = "https://github.com/rust-lang/libc" }

M main/polarplayer-studio/APKBUILD => main/polarplayer-studio/APKBUILD +0 -2
@@ 11,7 11,6 @@ builddir="$srcdir/$pkgname"
source="
	$pkgname-$pkgver.tar.gz::https://codeberg.org/comcloudway/polarplayer-studio/archive/$pkgver.tar.gz
	fix_icon_path.patch
	fix-musl.patch
"
options="net"



@@ 42,5 41,4 @@ package() {
sha512sums="
aff532d68025708b3d007506c76c49f4a2a2d061be4a666934bb17f56861023ab3072785759ec9c09045bec0db7ae3e080c33a225685439227908d3d5e114b05  polarplayer-studio-0.3.1.tar.gz
8c7d3b7313d38db3b51714ea10c7e3e2763ae8f8e589f37db146c55a6d980facb8ae4d9b21956d5d1ec13f0c47e80577baa1c29d0476ceb1e0cc9ce62abf7688  fix_icon_path.patch
18185025af47f9be5a4e82035c8d11aa97f0950c8fe4b83cf36fe2c60cc25f40a37cf1e9b9153d8f82ee50d7f223ca2f00f98850c89aa9807e15f6bfea66546b  fix-musl.patch
"

D main/polarplayer-studio/fix-musl.patch => main/polarplayer-studio/fix-musl.patch +0 -13
@@ 1,13 0,0 @@
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,6 +31,10 @@
 serde = { version = "1.0.132", features = ["derive"] }
 serde_json = "1.0"
 
+[patch.crates-io]
+getrandom = { git = "https://github.com/comcloudway/getrandom" }
+libc = { git = "https://github.com/rust-lang/libc" }
+
 [target.'cfg(target_os = "android")'.dependencies]
 #ndk      = { git = "https://github.com/nikita-skobov/android-ndk-rs", branch = "miniglue" }
 #ndk-glue = { git = "https://github.com/nikita-skobov/android-ndk-rs", branch = "miniglue" }

M testing/suitsquad/APKBUILD => testing/suitsquad/APKBUILD +0 -2
@@ 11,7 11,6 @@ makedepends="cargo libx11-dev mesa-dev libxi-dev"
source="
	$pkgname-$pkgver.tar.gz::https://codeberg.org/comcloudway/suitsquad/archive/$_pkgrelease.tar.gz
	fix-icon.patch
	fix-musl.patch
"
builddir="$srcdir/$pkgname"
options="net"


@@ 43,5 42,4 @@ package() {
sha512sums="
97c7a2448cd1457f560a3ccb260cd206fc7b0b1ed35cb54d76469828576ac13be6ac50746c779a469b531759bafd01a8a572605e1ef002a9db93ec4b6dc0fcf0  suitsquad-0.tar.gz
fbdad6df6cbb9782a81eb97f39a17b91d341922961cd0eef4a4d2876fb409ab6b798d6bd60f168d79615b4bd62f6e672012b01ee52cbdde3efd2206eb98505f1  fix-icon.patch
167c2389507657641925152110f98b003667cee45c10cd3db7556e2a89b6f667429119e79b36146707defe26fe2c17afa2fba298edb12784f3371033ac2bb376  fix-musl.patch
"

D testing/suitsquad/fix-musl.patch => testing/suitsquad/fix-musl.patch +0 -11
@@ 1,11 0,0 @@
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,6 +24,8 @@
 
 [patch.crates-io]
 sapp-android = { git = "https://github.com/sonicrules1234/miniquad" }
+getrandom = { git = "https://github.com/comcloudway/getrandom" }
+libc = { git = "https://github.com/rust-lang/libc" }
 
 [dev-dependencies]
 pretty_assertions = "0.6"