~comcloudway/ccw-aports

ab0016e2efbb9bbe918824b64b8182c75b656f1a — Jakob Meier 10 months ago 100220b
Updated README
4 files changed, 98 insertions(+), 117 deletions(-)

M .builds/002-build-commit.yml
M .builds/004-build-all.yml
A README.md
D README.org
M .builds/002-build-commit.yml => .builds/002-build-commit.yml +1 -1
@@ 44,7 44,7 @@ tasks:
        echo 'PACKAGER_PRIVKEY=$HOME/.abuild/comcloudway@ccw.icu.rsa' >> $HOME/.abuild/abuild.conf
        # start binfmt service for userspace emulation 
        # required by abuild-rootbld
        rc-service qemu-binfmt start
        sudo rc-service qemu-binfmt start
      fi
  - setup: |
      if [ -f ~/pkglist ]; then

M .builds/004-build-all.yml => .builds/004-build-all.yml +1 -1
@@ 45,7 45,7 @@ tasks:
        echo 'PACKAGER_PRIVKEY=$HOME/.abuild/comcloudway@ccw.icu.rsa' >> $HOME/.abuild/abuild.conf
        # start binfmt service for userspace emulation 
        # required by abuild-rootbld
        rc-service qemu-binfmt start
        sudo rc-service qemu-binfmt start
      fi
  - setup: |
      if [ ! -f ~/pkglist ]; then

A README.md => README.md +96 -0
@@ 0,0 1,96 @@
# CCW APORTS
This is my personal APKBUILD collection.

The official source code is located on [my personal sourcehut instance](https://git.hut.ccw.icu/~comcloudway/ccw-aports).


## Why not upstream your projects?
1. Most of my projects are not popular enough for me to publish them
2. If I were to publish them, I'd have to commit to maintaining the APKBUILD and the project. And I can't be bothered.

## Will you make prebuild binaries available?

My sourcehut CI is currently building and publishing the mirror [here](https://mirror.ccw.icu/).

[![builds.sr.ht status](https://builds.hut.ccw.icu/~comcloudway/ccw-aports/commits.svg)](https://builds.hut.ccw.icu/~comcloudway/ccw-aports/commits?)

You can find my public key [here](./comcloudway@ccw.icu.rsa.pub).

## Building packages using the APKBUILDs
Before you start building the packages,
you have to setup your developement environment.
The following two links might be helpful for that:
- [APKBUILD ref]](https://wiki.alpinelinux.org/wiki/APKBUILD_Reference)
- [Creating an alpine package](https://wiki.alpinelinux.org/wiki/Creating_an_Alpine_package)

After you finishes setting up your system,
we can move on.

First of all,
we need to clone this repo.
```sh
git clone https://git.hut.ccw.icu/~comcloudway/ccw-aports
```

To make the process easier,
you can use [cabin](https://git.hut.ccw.icu/~comcloudway/cabin) to build:
- everything
- one package
- a list of packages.

**`cabin` is also used to for the automatic builds**

To get started with cabin, have a look at the cabin README.

TLDR:
```sh
# prerequirement: setup alpine linux signing keys, install abuild and add package repo
# (see cabin README for more)

# index the repo
cabin scan

# build one package
cabin build oomph
# build multiple packages
cabin build-group oomph polarplayer-studio
# build all packages
cabin build-all
```

When you finished building the packages,
the build output can be found
in `$HOME/packages/ccw-aports/<subrepo>/<package>.apk`.

If you've added your local repo to your system repos (as you should when using cabin),
you can use to the following command to install the build packages:
```sh
apk add <package>
```
Otherwise you can use the `-X` option to specify the repository path
```sh
apk add -X $HOME/packages/ccw-aports/<subrepo> <package>
```

## HELP! Something isn't working.
Before you `panic!`,
please check the according projects README,
just in case you've missed something.

But if you are certain that the problem is related to the `APKBUILD`,
[send me an email](mailto:comcloudway@ccw.icu).

## License
All the APKBUILDs in this repo are licensed under MIT unless noted otherwise.

Keep in mind,
that whilst you can use the APKBUILDs to your liking, 
the MIT might not apply to the projects themselves.

# Useful resources
The following list is inpired by the [pmaports repo](https://gitlab.com/postmarketOS/pmaports)
- [How to create a package](https://wiki.postmarketos.org/wiki/Create_a_package)
- [APKBUILD ref](https://wiki.alpinelinux.org/wiki/APKBUILD_Reference)
- [Creating an alpine package](https://wiki.alpinelinux.org/wiki/Creating_an_Alpine_package)
- [Alpine Linux aports](https://gitlab.alpinelinux.org/alpine/aports/)
- [Alpine Linux package search](https://pkgs.alpinelinux.org/packages)

D README.org => README.org +0 -115
@@ 1,115 0,0 @@
* CCW APORTS
This is my personal APKBUILD collection.

The official source code is located over on [[https://codeberg.org/comcloudway/ccw-aports][codeberg]]
issues,
and pull requests on other platforms will be ignored.

**NOTE: The ~.apk~ files have nothing to do with AndroidPackages.**
**You need an Alpine Linux based distro to use/build them**

** Why not upstream your projects?
1. Most of my projects are not popular enough for me to publish them
2. If I were to publish them, I'd have to commit to maintaining the APKBUILD and the project. And I can't be bothered.

** Will you make prebuild binaries available?
Maybe.

For now you will have to build the projects yourself.
Instructions for doing so can be found in the next chapter.

In case I ever publish prebuild binaries:
you can find my public key [[./comcloudway@ccw.icu.rsa.pub][here]].

[[https://ci.ccw.icu/api/badges/comcloudway/ccw-aports/status.svg]]

** Building packages using the APKBUILDs
Before you start building the packages,
you have to setup your developement environment.
The following two links might be helpful for that:
- [[https://wiki.alpinelinux.org/wiki/APKBUILD_Reference][APKBUILD ref]]
- [[https://wiki.alpinelinux.org/wiki/Creating_an_Alpine_package][Creating an alpine package]]

After you finishes setting up your system,
we can move on.

First of all,
we need to clone this repo.
#+begin_src bash
git clone https://codeberg.org/comcloudway/ccw-aports
#+end_src

To make the process easier,
you can use the ~build.sh~ to build:
 - everything
 - one subrepo
 - one package

You can find out more about these build options below.

When you finished building the packages,
the build output can be found
in ~$HOME/packages/ccw-aports/<subrepo>/<package>.apk~.

To install a package from your build repo,
either add the path to the subrepo
(~$HOME/packages/ccw-aports/<subrepo>~) to ~/etc/apk/repositories~,
or run the following command to install packages from the repo,
replacing ~<subrepo>~ with the name of the subrepo,
and replcaing ~<package>~ with the name of the package.
#+begin_src bash
apk add -X $HOME/packages/ccw-aports/<subrepo> <package>
#+end_src

*** Building everything
To build every subrepo (expect ~broken~),
simply run;

#+begin_src bash
./build.sh all
#+end_src
*** Building one subrepo
If you want to build all packages from a specific subrepo,
run the following command replacing ~<subrepo-name>~,
with the subrepo of your choice,
e.g. ~main~.
#+begin_src bash
./build.sh repo <subrepo-name>
#+end_src
*** Building one package
If you want to build a specific package from a specific subrepo,
you can run the following command,
replacing ~<subrepo-name>~ with the subrepo of your choice,
and ~<package-name>~ with the package of your choice.
#+begin_src bash
./build.sh <subrepo-name> <package-name>
#+end_src

For example:
#+begin_src bash
./build.sh main blueprint
#+end_src

** HELP! Something isn't working.
Before you ~panic!~,
please check the according projects README,
just in case you've missed something.

But if you are certain that the problem is related to the ~APKBUILD~,
please file an issue on [[https://codeberg.org/comcloudway/ccw-aports][codeberg]].

** License
All the APKBUILDs in this repo are licensed under MIT unless noted otherwise.

Keep in mind,
that whilst you can use the APKBUILDs to your liking, 
the MIT might not apply to the projects themselves.


* Useful resources
The following list is inpired by the [[https://gitlab.com/postmarketOS/pmaports][pmaports repo]]
- [[https://wiki.postmarketos.org/wiki/Create_a_package][How to create a package]]
- [[https://wiki.alpinelinux.org/wiki/APKBUILD_Reference][APKBUILD ref]]
- [[https://wiki.alpinelinux.org/wiki/Creating_an_Alpine_package][Creating an alpine package]]
- [[https://gitlab.alpinelinux.org/alpine/aports/][Alpine Linux aports]]
- [[https://pkgs.alpinelinux.org/packages][Alpine Linux package search]]