~comcloudway/ccw-aports

3f7265b512ba2a18c91c01b2382f7f26e46422c1 — Jakob Meier 1 year, 8 months ago 0f2be83
Fixed apkbuild
1 files changed, 8 insertions(+), 9 deletions(-)

M testing/vlang/APKBUILD
M testing/vlang/APKBUILD => testing/vlang/APKBUILD +8 -9
@@ 2,13 2,13 @@
# Maintainer: Jakob Meier <comcloudway@ccw.icu>
pkgname=vlang
pkgver=0.3.2
pkgrel=2
pkgrel=0
pkgdesc="Simple, fast, safe, compiled language for developing maintainable software."
url="https://vlang.io"
arch="all"
license="MIT"
depends="gc-dev"
makedepends="tcc clang"
makedepends="tcc clang libexecinfo"
checkdepends=""
subpackages=""
source="vlang-$pkgver.tar.gz::https://github.com/vlang/v/archive/refs/tags/$pkgver.tar.gz


@@ 25,8 25,7 @@ build() {
	
	# disable `v up`
	# as seen in AUR package
  echo "println('v up is disabled; see the AUR page for more information.')" \
		> 'cmd/tools/vup.v'
    echo "println('v up is disabled')" > cmd/tools/vup.v

	# cannot rely on prebuild tcc libgc.a
	# needs gc-dev


@@ 35,7 34,7 @@ build() {
	echo building v using c
	tcc -std=gnu11 -w -o v1 vc/v.c -bt10 -lm -lexecinfo -lpthread
	echo building stage 2
	./v1 -no-parallel -o v2 -cc tcc cmd/v
	./v1 -no-parallel -o v2 cmd/v
	echo building v staging
	./v2 -o v -cc tcc cmd/v



@@ 54,11 53,11 @@ check() {
	# also some of them seem quite useless
	# and others fail
	# make check
	echo who cares right?
    :
}

package() {
	  install -d $pkgdir/usr/lib/vlang $pkgdir/usr/share/vlang $pkgdir/usr/bin
	install -d $pkgdir/usr/lib/vlang $pkgdir/usr/share/vlang $pkgdir/usr/bin
    install -Dm644 LICENSE pkgdir/usr/share/licenses/$pkgname/LICENSE
    install -Dm755 v $pkgdir/usr/lib/vlang
    cp -a cmd $pkgdir/usr/lib/vlang/


@@ 66,12 65,12 @@ package() {
    cp -a thirdparty $pkgdir/usr/lib/vlang/
    cp -a vlib $pkgdir/usr/lib/vlang/
    cp v.mod $pkgdir/usr/lib/vlang/
    ln -s /usr/lib/vlang/v $pkgdir/usr/bin/v
    ln -s usr/lib/vlang/v $pkgdir/usr/bin/v

    touch $pkgdir/usr/lib/vlang/cmd/tools/.disable_autorecompilation
}
sha512sums="
ffe9880187ac8d20468c2c625c0f624e51096f78405d0af35444ce6eb25067b7f7ef35d6d30907eea339902749be96d715af8df33e5d5427d007337d375bb642  vlang-0.3.2.tar.gz
80fbdb05e7859c45f803a0a42bd313d988671af3b624e237ead10478485fd2a7ec849f9c77cbe7e08135c1611cbfdbd62345cf2db4c8b1e1fe22f7549de3b244  vlang-0.3.3.tar.gz
c8714a149d03e73e909dd298c1aae6a34190acc64d4988fb388dbd03d2d58882ca1bc09c0a4a85557ca511306426d9aae356506d2ee118caf08e0a4899cfe089  vc.c
ee9f916092bafd1dfc782354291443261fd33bad7fe9663422211f36cb75b59b54f85a5b8a68ce5d7c222ef13cbb3379434b13e4af3f89a78fdadbab9425a22b  tcc.tar.gz
474cfbe8952640d49a80a8278dcedfb0a7ecca01ea83aa5acb7514530b8ac5efa08ecbd9d572608069855c1936e1de51fbbb11b7fd262980612269d4979a89fe  explicit_cast.patch