A => .gitignore +2 -0
A => README.org +49 -0
@@ 1,49 @@
+* comcloudway private APKBUILD repo
+This is my personal APKBUILD collection.
+
+**NOTE: The ~.apk~ files have nothing to do with AndroidPackages.**
+**You need an alpine linux based distro to use/build them**
+
+** Why not upstream your projects?
+1. Most of my projects are not popular enough for me to publish them
+2. If I were to publish them, I'd have to commit to maintaining the APKBUILD and the project. And I can't be bothered.
+
+** How to install a project from here?
+1. Clone this git repo
+ #+begin_src bash
+ git clone https://codeberg.org/comcloudway/apks ccw-repo
+ cd ccw-repo
+ #+end_src
+2. Find the project you want to build.
+ There aren't many projects in here (yet).
+
+ But assuming you want to build ~polarplayer-studio~,
+ you can use the following commands (replace ~polarplayer-studio~ with the name of project you want to build)
+
+ #+begin_src bash
+ cd polarplayer-studio
+ abuild -r
+ #+end_src
+3. After the build finished,
+ you should be able to find
+ that ~abuild~ generated a repo in ~$HOME/packages/ccw-repo~.
+
+ Depending on the architecture of your computer,
+ the build output can now be found in ~$HOME/packages/ccw-repo/$arch~.
+ Most computers probably use the ~x86_64~ architecture,
+ but when you are building this on a pinephone it should be ~aarch64~.
+
+ In case you do not know your architecture,
+ you are in luck,
+ because you do not have to,
+ as ~apk~ will take care of this for you.
+
+ To install the package you build you can use the following command:
+ #+begin_src bash
+ apk add --repository $HOME/packages/ccw-repo polarplayer-studio
+ #+end_src
+4. Congratualtions!
+ You've installed a program from my repo.
+
+** Will you make prebuild binaries available?
+Maybe.
A => polarplayer-studio/APKBUILD +37 -0
@@ 1,37 @@
+# Maintainer: Jakob Meier <comcloudway@ccw.icu>
+pkgname=polarplayer-studio
+pkgver=v2
+pkgrel=0
+pkgdesc="PolarPlayer Studio is a MIDI synth for the ROLI Seaboard or other MIDI instruments that send pressure data."
+url="https://codeberg.org/comcloudway/polarplayer-studio"
+arch="all"
+license="AGPL-3.0"
+depends=""
+makedepends="cargo alsa-lib alsa-lib-dev"
+checkdepends=""
+install=""
+#subpackages="$pkgname-dev $pkgname-doc"
+builddir="$srcdir/$pkgname"
+source="$pkgname-$pkgver.tar.gz::https://codeberg.org/comcloudway/polarplayer-studio/archive/$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ cargo fetch --locked
+}
+
+build() {
+ cargo build --frozen --release
+}
+
+check() {
+ cargo test --frozen
+}
+
+package() {
+ cargo install --frozen --offline --path . --root="$pkgdir/usr"
+ rm "$pkgdir"/usr/.crates*
+}
+
+sha512sums="
+8aba1c49df9b47e819f37548aa9705571518b9c35d5b725b3c0c04f702a8ddc14da890720a81c85d4c805555cea46c5942572ccd3d06cc3dba952a983d8538f5 polarplayer-studio-v2.tar.gz
+"