M .woodpecker.yml => .woodpecker.yml +3 -2
@@ 8,7 8,8 @@ pipeline:
- doas sh -c "echo 'http://dl-cdn.alpinelinux.org/alpine/edge/testing' >> /etc/apk/repositories"
- doas apk update
- doas apk add fd bash abuild dateutils
- - echo '$PACKAGE_SIGNATURE' > $PWD/.comcloudway@ccw.icu.rsa
- - doas su -c "echo 'PACKAGER_PRIVKEY=$PWD/.comcloudway@ccw.icu.rsa' >> /etc/abuild.conf"
+ - doas su -c "echo '$PACKAGE_SIGNATURE' > $PWD/comcloudway@ccw.icu.rsa"
+ - doas su -c "echo 'PACKAGER_PRIVKEY=$PWD/comcloudway@ccw.icu.rsa' >> /etc/abuild.conf"
+ - doas chown -R $USER $PWD
- ./build.sh all
secrets: [ package_signature ]
M README.org => README.org +2 -0
@@ 21,6 21,8 @@ Instructions for doing so can be found in the next chapter.
In case I ever publish prebuild binaries:
you can find my public key [[./comcloudway@ccw.icu.rsa.pub][here]].
+[[https://ci.ccw.icu/api/badges/comcloudway/ccw-aports/status.svg]]
+
** Building packages using the APKBUILDs
Before you start building the packages,
you have to setup your developement environment.
M build.sh => build.sh +1 -1
@@ 1,7 1,7 @@
#!/bin/sh
# Needs: fd, bash, abuild, dateutils
-set -eu
+set -eu -o pipefail
# Build a specific package
# Arg 1: the repo path (e.g. broken, main or testing)